79 lines
2.2 KiB
Nix
79 lines
2.2 KiB
Nix
{ lib, config, pkgs, ... }:
|
|
{
|
|
programs.zed-editor = lib.mkIf config.meta.home-manager.vscode.enable {
|
|
enable = true;
|
|
|
|
extensions = [
|
|
# Language support
|
|
"nix" "toml" "deno" "kotlin"
|
|
# Themes
|
|
"catppuccin"
|
|
];
|
|
|
|
userSettings = {
|
|
auto_update = false;
|
|
base_keymap = "VSCode";
|
|
load_direnv = "shell_hook";
|
|
show_whitespaces = "boundary";
|
|
tab_size = 4;
|
|
theme = "Catppuccin Mocha";
|
|
buffer_font_family = "FiraCode Nerd Font";
|
|
format_on_save = "off";
|
|
soft_wrap = "none";
|
|
|
|
terminal = {
|
|
dock = "bottom";
|
|
font_family = "FiraCode Nerd Font";
|
|
font_size = 14;
|
|
line_height = "standard"; # Comfortable breaks my powerline
|
|
working_directory = "current_project_directory";
|
|
env.TERM = "xterm-256color";
|
|
};
|
|
|
|
lsp = {
|
|
rust-analyzer = {
|
|
binary = {
|
|
path = lib.getExe pkgs.rust-analyzer;
|
|
};
|
|
};
|
|
|
|
nix = {
|
|
binary = {
|
|
path = lib.getExe pkgs.nixd;
|
|
};
|
|
};
|
|
|
|
vtsls = {
|
|
binary = {
|
|
path = lib.getExe pkgs.vtsls;
|
|
arguments = [ "--stdio" ];
|
|
};
|
|
};
|
|
|
|
kotlin-language-server = {
|
|
binary = {
|
|
path = lib.getExe' pkgs.kotlin-language-server "kotlin-language-server";
|
|
};
|
|
};
|
|
};
|
|
|
|
languages = {
|
|
Nix = {
|
|
language_servers = [ "nixd" "!nil" ];
|
|
};
|
|
};
|
|
|
|
# Disable the bullshit
|
|
assistant = {
|
|
enabled = false;
|
|
button = false;
|
|
version = "1";
|
|
};
|
|
features.inline_completion_provider = "none";
|
|
telemetry = {
|
|
diagnostics = false;
|
|
metrics = false;
|
|
};
|
|
};
|
|
};
|
|
}
|