nix/home-manager/default.nix

31 lines
No EOL
1.1 KiB
Nix
Executable file

{ inputs, system, secrets, lib, config, ... }:
{
options.ty-home-manager-options = {
plasma.enable = lib.mkEnableOption "plasma configuration";
firefox.enable = lib.mkEnableOption "firefox configuration";
thunderbird.enable = lib.mkEnableOption "thunderbird configuration";
vscode.enable = lib.mkEnableOption "vscode configuration";
beets.enable = lib.mkEnableOption "beets configuration";
rescrobbled.enable = lib.mkEnableOption "rescrobbled configuration";
};
config = {
home-manager.useGlobalPkgs = true;
home-manager.useUserPackages = true;
home-manager.sharedModules = [
inputs.plasma-manager.homeManagerModules.plasma-manager
./custom-modules
];
home-manager.extraSpecialArgs = {
inherit inputs system secrets;
inherit (config) ty-home-manager-options;
};
home-manager.backupFileExtension = "backup";
home-manager.users.ty = {
imports = [
./home.nix
];
};
};
}